Blog

XE 사용을 위한 서버 환경 지원에 대한 변경 사항을 알립니다.

XE는 PHP 5.2.4버전부터 이용할 수 있었으나, PHP 5.2.x는 2011년 1월을 마지막으로 보안 취약점 패치를 포함한 모든 지원이 종료되었습니다.
계속하여 PHP 5.2버전대를 사용할 경우 PHP 자체의 매우 심각한 보안 취약점에 의한 공격 가능성을 안고 있을 수 있습니다.

XE 1.8부터 PHP 5.2 버전대를 지원하지 않습니다. 자세한 내용을 아래 내용을 참고해주시기 바랍니다.

PHP 지원 버전 안내

  • 최소 지원 버전 : PHP 5.3 이상
    • PHP의 심각한 보안 취약점으로 인해 PHP 5.3.13 버전 이상을 권장합니다
  • 권장 버전 : PHP 5.5 이상

'최소 지원 버전'은 XE가 동작할 수 있는 최소 버전이며, 미래에 XE의 PHP 버전 지원 범위 변경과 보안 향상을 위해 최신의 PHP 안정 버전 사용을 권장합니다.

PHP.net에서 최신 안정버전을 확인할 수 있습니다.

지속적 지원 범위 변경 예고

XE 1.8의 PHP 최소 지원 버전으로 가리키고 있는 PHP 5.3 또한 2014년 이미 모든 지원이 종료된 상태입니다.
웹호스팅 사용자가 서버 환경의 변경에 어려움을 고려하여 보수적으로 최소 지원 버전을 채택하였습니다.

짧게는 6개월 이내에 지속적으로 PHP 버전 지원 정책이 변경될 수 있으니 최신의 안정된 PHP 환경으로 변경하시길 권장합니다.

PHP의 버전 현황

아래 현황은 보안 취약점에 대한 지원 사항을 포함한 종료 일정이며, 지원이 종료된 버전 현황과 버전별 지원 현황을 요약한 것입니다.

  • PHP 5.2 : 2011년 1월 지원 종료
  • PHP 5.3 : 2014년 8월 지원 종료
  • PHP 5.4 : 2015년 9월 지원 종료 예정
  • PHP 5.5 : 2016년 6월 지원 종료 예정

php Supported Versions.png
2015년 3월 17일 기준 지원 현황

PHP 지원 범위 변경에 의한 영향

지원 버전 미만의 버전에서 XE의 일부 또는 전체 기능이 동작하지 않을 수 있습니다.
이는 정상적인 구동이 불가함을 뜻하며 사이트 구동이 완전히 정지할 수 있습니다.

PHP 지원 범위 변경에 따른 변경 사항

  • XE 1.8은 PHP 5.3 미만의 환경에서 설치할 수 없습니다
  • XE 1.7의 최종 버전(1.7.12 배포 예정)에서 쉬운설치로 업데이트할 수 없도록 차단할 예정입니다
    • XE 1.7 최종 버전 미만에서는 PHP 버전을 확인하지 않으므로 쉬운설치를 통해 XE 1.8 이상으로 업데이트 시 주의하시기 바랍니다

사용 중인 서버의 PHP 버전 확인 방법

PHP 버전의 확인은 사용 중인 서버의 서버 관리자(웹호스팅 서비스를 제공하는 회사, 서버를 구성한 자 등)에게 문의하여 확인하실 수 있으며, 다음과 같이 확인할 수 있습니다.

설치된 XE에서 확인하는 방법

XE 1.7.4 이상의 관리자 페이지에서 하단의 '서버정보출력' 링크를 통해 PHP 버전을 확인할 수 있습니다.

파일을 이용한 확인

아래의 코드를 phpversion.php로 파일을 생성하여 확인하고자 하는 서버에 업로드하여 확인할 수 있습니다.
브라우저에서 해당 파일의 주소('도메인/phpversion.php')를 열어보면 해당 서버의 PHP 버전이 출력됩니다.

<?php echo phpversion();

PHP 버전 업그레이드 방법

서버 관리자에게 요청하거나 관련 매뉴얼을 참고하시기 바랍니다.

 

 

태그 연관 글
  1. [2017/01/12] Blog [보안 패치] XE 1.8.28, 1.8.29 배포 안내 by XE *1
  2. [2016/12/07] 묻고답하기 유튜브(YouTube) 모듈 반응형으로!!! by 힐디
  3. [2016/10/28] Blog [보안 패치] XE 1.8.27 배포 안내 by XE
  4. [2016/10/10] Blog [보안패치] XE 1.8.26 배포 안내 by XE
  5. [2016/09/23] Blog XE 1.8.25 배포 안내 by XE *1
제목 최종 글 날짜
공지 XE 신규 보안취약점 신고 포상제 시행 안내 [1] 2016.10.04 by 댑펑 2016.09.30
공지 XE Core 1.8의 PHP 지원 버전 변경 안내 [20] 2015.12.02 by alibatur 2015.03.17
[보안 패치] XE 1.8.28, 1.8.29 배포 안내 [1] 2017.01.18 by YJSoft 2017.01.12
XECon 2016 여러분을 초대합니다 [4] file 2017.01.05 by 최혁762 2016.11.09
[보안 패치] XE 1.8.27 배포 안내   2016.10.28
[보안패치] XE 1.8.26 배포 안내   2016.10.10
XE 1.8.25 배포 안내 [1] 2016.09.24 by 에릭리카드 2016.09.23
XECon 2016 발표자를 모십니다 file   2016.09.02
XE Open Seminar - XE3 A부터 Z까지(4/4) - 좀 더 쉬워진 테마 제작 [3] file 2016.09.03 by CosignStudio 2016.08.25
[연기 됨] XE Open Seminar - XE3 A부터 Z까지(3/4) - TODO List 컴포넌트 제작   2016.08.22
[보안패치] XE 1.8.24 배포 안내 [3] 2016.12.30 by 재윤이 2016.08.05
[보안 패치] XE 1.8.23 배포 안내 [3] 2016.08.05 by gu곰 2016.08.02
XE 1.8.22 배포 안내   2016.06.29
XE 1.8.21 배포 안내 [2] 2016.06.25 by bncPlan 2016.06.16
XE 1.8.20 배포 안내 [2] 2016.05.28 by kjmedi626 2016.05.16
XE Open Office Day - XE3 First meet up [1] 2016.05.26 by 해피지영 2016.05.16
XE 1.x 프로젝트 Github 이슈 정리에 대한 안내 [8] 2016.05.05 by 독도2005 2016.05.02
[보안패치] XE 1.8.19 배포 안내 [3] 2016.04.25 by 별이엄마 2016.04.15
XE Open Seminar - XE3 테마 만들기 [1] 2016.05.16 by akasima 2016.04.14
XE Open Seminar - XE3 기본기부터 플러그인 개발까지 (한번더) [20] file 2016.04.11 by XE 2016.03.15
XE 1.8.18 배포 안내   2016.03.08