메뉴 건너뛰기

league/flysystem-aws-s3-v3 ~1.0 컴포저 설치 오류입니다

컴포저를 통해 s3 플러그인을 설치하려는데,

no-plugins 옵션을 주어도 설치가 되지 않습니다.

도움 좀 부탁드립니다 ㅜㅜ

[콘솔에러본문]

ubuntu@ip-172-31-21-245:~/web$ composer require league/flysystem-aws-s3-v3 ~1.0 --no-plugins
./composer.json has been updated
> Xpressengine\Plugin\Composer\Composer::command
> Xpressengine\Plugin\Composer\Composer::preUpdateOrInstall
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - xpressengine/installer 1.1.0 requires composer-plugin-api 1.1.* -> no matching package found.
    - xpressengine/installer 1.1.0 requires composer-plugin-api 1.1.* -> no matching package found.
    - xpressengine/installer 1.1.0 requires composer-plugin-api 1.1.* -> no matching package found.
    - Installation request for xpressengine/installer == 1.1.0.0 -> satisfiable by xpressengine/installer[1.1.0].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.
 

포럼의 다른 글