Blog

XE 1.10.x의 릴리즈 계획은 취소 되었으며, 이전에 안내한 아래의 내용 또한 더 이상 유효하지 않습니다.
 

 

XE1이 구동하기 위한 PHP 최소 지원 변경을 안내합니다.

2018년 3월로 예정하고 있는 XE 1.10.0버전부터 PHP 최소 요구사항이 변경됩니다.
지정된 최소 지원 버전이하의 서버 환경에서는 XE가 동작하지 않을 수 있으며, PHP의 특성 변화로 인한 오동작 가능성이 있습니다.

PHP 지원 변경에 따른 문제를 미리 확인하여 서버 환경을 점검하시기 바랍니다.

PHP 지원 버전 안내

  • 최소 지원 버전 : PHP 5.6.4
  • 권장 버전 : PHP 7.0 이상
  • 반영 예정 : XE Core 1.10 (2018년 3월 중 배포 예정)
  • 변경 사유 : PHP 언어의 특정 기능 사용 및 외부 라이브러리 요구 사항의 반영

PHP 버전에 따른 영향

  • XE 1.10.x 이상은 PHP 5.6.4 미만의 환경에서 설치하거나 사용할 수 없습니다
  • PHP 5.6 미만의 환경에서는 XE 1.10 이상으로 업데이트 시 사이트가 동작하지 않을 수 있습니다
  • PHP 5.6 ~ PHP 7.1 버전을 사용해야하며, PHP 7.2 이상에서는 확장 기능(모듈, 애드온 등)이 PHP 7.2와 호환성 문제를 가지고 있을 수 있으므로 확장 기능 사용에 주의하시기 바랍니다

PHP의 버전 현황

이번 PHP 지원 버전 변경은 XE 1.8.x의 PHP 버전 요구 사항 변경 이후 약 3년 만의 변경입니다.

아래 현황은 PHP 보안 취약점에 대한 지원 사항을 포함한 종료 일정이며, 지원이 종료된 버전 현황과 버전별 지원 현황을 요약한 것입니다.

  • PHP 5.3 : 2014년 8월 지원 종료
  • PHP 5.6 : 2018년 12월 종료 예정
phpversion.png

 

PHP 버전 확인 : 설치된 XE에서 확인하는 방법

XE 1.7.4 이상의 관리자 페이지에서 하단의 '서버정보출력' 링크를 통해 PHP 버전을 확인할 수 있습니다.

PHP 버전 확인 : 파일을 이용한 확인

아래의 코드를 phpversion.php로 파일을 생성하여 확인하고자 하는 서버에 업로드하여 확인할 수 있습니다(확인 후 삭제하세요).
브라우저에서 해당 파일의 주소('도메인/phpversion.php')를 열어보면 해당 서버의 PHP 버전이 출력됩니다.

<?php echo phpversion();

PHP 버전 업그레이드 방법

서버 관리자에게 요청하거나 관련 매뉴얼을 참고하시기 바랍니다.

서버 환경의 변경이 불가할 수 있는 웹호스팅 등의 환경에서는,
호스팅사에 문의하여 서버 이전 등이 가능한지 확인하시기 바랍니다.