메뉴 건너뛰기

공지
XE 3.0.12 릴리즈 노트

안녕하세요! XE팀입니다.

2020년 9월 21일, XE 3.0.12 버전이 릴리즈되었습니다. 
아래와 같은 기능 개선, 버그 수정이 진행되었습니다. 여러분의 다양한 피드백과 제안 부탁드립니다.

 

개선 사항

  • 에러가 발생 했을 때 기존 에러코드를 반환하도록 수정 (276b169)
  • #1172 PluginNoutFoundException에서 플러그인 이름이 출력 안되는 문제 수정
  • 에디터에서 upload 권한이 없을 경우 기능 비활성화 처리
  • 기본 썸네일 생성 방식을 spill로 변경 (81ad22e)

 

문제 패치

  • 미디어라이브러리에서 썸네일 생성이 안 될 수 있는 문제 수정(276b169)
  • #1145 윈도우 환경에서 컨트롤러를 통해 플러그인 업데이트시 발생하는 에러 수정
  • #1159 디버깅 모드에서 DateTIme converted to string 에러 수정
  • #1141 윈도우 환경에서 xe:update 버전 인식 못 하는 문제 수정
  • #1164 윈도우 환경에서 private:update 명령어 실행 안되는 문제 수정
  • #1163 플러그인에 vendor가 없는 dependency를 추가하면 update 안되는 문제 수정
  • #1175 FormSelectUIO에서 다중 선택이 안되는 버그 수정
  • 관리자 메뉴를 추가 할 때 링크 형식 메뉴 추가가 안되는 문제 수정(bfa28b9)
  • ThemeSelectUIO에 테마의 목록을 전달 했을 때 목록 출력이 안되는 문제 수정(41b09ca)

 

업데이트 주의사항

  • SSH(터미널)환경에서 업데이트 하는 경우 업데이트 가이드를 참고하시기 바랍니다.
  • 서비스 중인 사이트에 적용하시기 전에 서비스 중인 사이트와 유사한 환경을 갖추고 이상이 없는지 확인하시길 권고합니다.
  • 업데이트 전 관리자 로그인 상태로 관리페이지를 열어두시고 진행하시길 권고합니다.
  • 업데이트 후 플러그인들을 업데이트해야 합니다.
  • 업데이트 후 캐시를 갱신하셔야 합니다.
  • 업데이트 후 오류가 발생한다면 storage/app/interception 디렉토리에 있는 모든 파일들을 삭제하시기 바랍니다.

 

업데이트시 알아두세요

  • 웹 업데이트 기능을 사용하기 위해서는 php binary가 사용 가능한지 확인해야 합니다.
  • SSH 프로그램(Putty 등)을 사용하여 서버에 접속후 " php -v " 명령을 실행하여, PHP의 버전 정보가 정상적으로 표시되는지 확인해주세요.
  • php binary가 사용 불가능한 환경이라면, cgi api (php-fpm)로 PHP가 구동되는지 확인해주세요.
  • php binary를 사용할 수 없으며, cgi api를 사용하는 환경에서는 정상적으로 업데이트가 실행되지 않을 수 있으니, 업데이트가 가능한 다른 서버 또는 로컬PC에서 FTP 등을 이용하여 서비스에 적용 후 이용하시기 바랍니다.
  • 자동 업데이트는 소스파일이 변경되는 작업이 수행되기 때문에, 프로젝트 루트에 파일 쓰기 권한이 필요합니다.
  • 꼭 루트의 파일 쓰기 권한 또는, php binary를 꼭 확인해주세요!!

 

더 알아보기

  • 제작한 플러그인을 배포할 수 있는 XE Store에 방문해보세요.
  • XE3 가이드로 궁금한 점을 해결해보세요.
  • FAQ와  XE 블로그에 공유된 정보로 문제를 해결해 보세요.
  • Q&A 게시판에 궁금한 점을 남겨 답변을 받아보세요. 
  • XE3는 여러분의 기여를 기다리고 있습니다. Pull Request 작성 가이드를 확인해보세요.
  • share