Blog

XpressEngine Core 1.9.0 버전을 배포합니다.

이 버전에서는 보안 문제가 고쳐졌으며, 모든 사용자에게 업데이트를 권장합니다.

PHP 7.2 이상에서 발생하는 문제를 고쳤습니다.
버전이 1.8.x에서 1.9.x로 크게 증가한 것은 이 호환성 개선이 적용되었음을 나타내기 위함입니다.
이는 PHP 7.2 이상의 서버 환경에 대한 호환성 개선 대응이며, 기존 사용자에게는 영향이 없습니다.

서버의 PHP 7.2 업그레이드 시 주의 사항

현재 PHP 7.2는 정식 버전이 아니며, RC6이 배포되었습니다.

이 배포본에서는 PHP 7.2에 대한 호환성 문제를 고쳤으나, 배포본 외의 업데이트되지 않은 확장 기능 사용 시 문제가 발생할 수 있습니다. 관련 정보는 https://www.xpressengine.com/devlog/23249915 에서 찾아볼 수 있습니다.

 

Core 업데이트 주의 사항

  • 실 사이트에 적용하시기 전에 실 사이트와 유사한 환경을 갖추고 이상이 없는지 확인하시길 권고합니다.
  • 업데이트 전 관리자 로그인 상태로 관리페이지를 열어두시고 진행하시길 권고합니다.
  • 업데이트 후 대시보드에서 각 모듈의 DB 생성 및 업데이트 버튼을 누르세요.
    • 업데이트 순서는 'menu > module > 기타 모듈'순서로 해 주시기 바랍니다.
  • 업데이트 후 관리페이지 우측 하단의 캐시파일 재생성으로 cache를 갱신하셔야 합니다.
  • 1.4 및 1.5 버전에서 업데이트하는 경우 데이터 양에 따라 시간이 많이 소요될 수 있으며 서버 환경에 따라 업데이트에 실패할 수 있습니다.
  • 다음 문서를 참고하여 데이터 백업 후 진행하시길 권고합니다.

문제 발견 시 알려주세요

이 버전에서 발견된 문제는 XE Core 프로젝트 페이지에 이슈를 작성해주시기 바랍니다.

신규 보안 취약점 포상제

XE의 보안취약점의 빠른 발견과 해결을 위해 신규 보안취약점에 대한 신고 포상제를 시행합니다.

그동안 XE 보안취약점은 한국인터넷진흥원(KISA)를 통해 접수되어 통보받는 형태로 운영되어 왔습니다.
하지만 신고자와의 긴밀한 연락이 불가하고, 신고자의 정보를 파악할 수 없어 오픈소스 소프트웨어의 공헌자로서 그 이름을 알리지 못했었습니다.

지속적으로 보안 취약점을 발견하고 해결해나가기위해 자체적인 보안 취약점 신고 절차와 신규 보안 취약점 신고자에 대한 포상제를 시행합니다.

보안 취약점 신고 포상제 페이지를 통해 보안 취약점의 신고 절차를 확인할 수 있습니다.

많은 분들이 공헌해주셨습니다

XE는 자유소프트웨어로서 공개 프로젝트로 운영하고 있습니다.
XE Core 프로젝트 페이지에서 버그 보고 및 개선 제안과 개발에 참여할 수 있습니다.

XE 1.8 미리보기

XE Demo에서 XE 1.8을 미리 사용해볼 수 있습니다.

초기 설치 상태 그대로의 모습으로 최고관리자 권한을 이용해 쉬운설치 및 XE 1.8의 모든 기능을 체험해볼 수 있습니다.

다운로드

XE Core 다운로드 페이지에서 XE 최신 버전을 다운로드할 수 있습니다.

이 버전의 직전 버전을 사용 중이신 경우 변경된 파일(파일명에 'changed'가 포함된 파일)만 내려받아 업데이트할 수 있습니다.

변경 내역

Secutiry

New Feature

  • #2172 게시물의 업데이트 상태를 나타내는 아이콘을 지정할 수 있는 설정 추가 @bjrambo
    • modules/document/tpl/icons 밑에 폴더를 만들어 아이콘을 추가해두면 설정에서 적용할 수 있습니다
    • default 폴더를 참고하여 파일 이름과 확장자가 동일해야 합니다
    • 일부 확장 기능에서는 이 설정이 반영되지 않을 수 있습니다

Defect

  • #2155 #2168 게시물 주소에 MID를 추가하여 게시물 주소의 일관성 개선 @smaker @bnu @wookho
  • #2174 페이지에 링크가 많을 때 브라우저 성능을 저하시키거나 오류가 발생할 수 있는 문제 고침 @bnu @kijin@wookho
  • #2176 항상 로드하는 내장 스크립트를 중복 로드하는 문제 고침 @bnu @wookho
  • #1683 fix #1673 파일 첨부 허용 확장자 오류 메시지 출력 시 잘못된 메시지를 출력하는 문제 고침 @YJSoft@bnu @bjrambo @phin1000
  • #1604 DB 설정 파일을 직접 편집 시 BOM으로 발생할 수 있는 문제 고침 @wkpark
  • #1571 fix #1523 다국어 문법 문제 고침 @YJSoft @kijin
  • #1848 32비트 환경에서 2GB 이상 첨부파일을 다운로드할 때 발생하는 문제 고침 @hletrd

Enhancement

  • #1649 통합검색 모듈 번역 개선 @dorami
  • #1631 ob_gzhandler 대신 zlib.output_compression 사용 @kijin

For Developers

  • #2181 PHP 7.2 Object 클래스의 이름 충돌로 인한 클래스 이름 변경 @bnu @kijin
    • PHP 7.2에서 Object 이름을 가진 클래스를 사용 시 Fatal Error 발생
    • XE의 범용 클래스인 Object 이름을 사용할 수 없게 되어 BaseObject로 변경
    • PHP 7.2에서는 확장 기능에서도 문제를 일으킬 수 있습니다. 관련 정보는 이슈를 참고해주세요
  • #1679 fix #1677 MSSQL 쿼리 구문 오류 문제 고침 @RapidWorkers
  • #1623 모바일에서도 API를 사용할 수 있도록 변경 @zfanta
  • #1765 Context 클래스의 멤버 변수의 잘못된 정보 고침 @vomvoru
 
 
제목 최종 글 날짜
공지 [중요!] Object 클래스의 이름 변경 안내(PHP 7.2 버전 호환성) [1] 2017.11.28 by 엘카 2017.11.27
공지 XE 신규 보안취약점 신고 포상제 시행 안내 [1] 2017.02.25 by 댑펑 2016.09.30
공지 XE Core 1.8의 PHP 지원 버전 변경 안내 [21] 2017.10.27 by ylq159321 2015.03.17
XE 1.9.2(1.9.1 포함) 배포 안내 (OPcache 문제 수정) [2] 2017.12.08 by 마카리아 2017.12.07
[보안패치] XE 1.9.0 배포 안내 (PHP 7.2 호환성 개선) [12] 2017.12.04 by XE 2017.11.30
[보안패치] XE Core 1.8.46 배포 안내 [6] 2017.10.27 by 숭숭군 2017.10.19
[보안패치] XE Core 1.8.45 버전 배포 안내 [5] 2017.10.01 by 우랑탕탕이 2017.09.12
[보안패치] XE Core 1.8.44 버전 배포 안내 [1] 2017.09.12 by 웹마스터 2017.09.12
[보안패치] XE Core 1.8.43 버전 배포 안내 [5] 2017.08.27 by 흑묘백묘 2017.08.17
XE Open Office Day - XE3 Boot up #1   2017.08.17
XE Core 1.8.42 버전 배포 안내 [5] 2017.07.25 by 에릭리카드 2017.06.27
XE Core 1.8.41 버전 배포 안내   2017.06.09
마켓허브 연동 오류 및 복구를 위한 요청 [1] 2017.06.07 by 착한악마 2017.06.07
XE Core 1.8.40 버전 배포 안내 [6] 2017.06.06 by 장년 2017.06.02
[보안패치] XE Core 1.8.39 버전 배포 안내 [5] 2017.06.01 by 장년 2017.05.31
[해결됨] XE1 Core GitHub 저장소 일시 비공개 처리 안내   2017.05.30
[보안패치] 1.8.38 버전 배포 안내 [1] 2017.05.29 by 에릭리카드 2017.05.29
XE 1.8.37 배포 안내   2017.04.17
[보안패치] XE 1.8.36 배포 안내   2017.04.14
[완료] 3월 18일 : 서버 이전에 따른 서비스 일시 중단 안내   2017.03.09
[중요! 보안패치] 1.8.34 버전 배포 안내   2017.03.08
개인정보 처리방침 개정 안내   2017.03.08