Blog

XpressEngine Core 1.9.8 버전을 배포합니다.

이 버전에서는 버그 수정과 다수 개발자의 코드 기여에 의한 개선 사항이 포함됩니다.

이전 버전(1.9.7)에서 XE Core의 쉬운 설치 기능이 제한되었던 것에 대해 불편을 이야기 해주셔서 다음과 같이 변경하였습니다.

적용되었던 제한 사항 : XE Core(1.9.7)를 쉬운 설치로 업데이트 할 수 없음
변경된 제한 사항 : XE Core를 쉬운설치로 업데이트 할 수 있으나, XE Core의 업데이트 요구하는 플러그인은 XE Core를 먼저 업데이트 해야 함

이는 1.9.8 버전 이상에서 적용된 사항이며, 1.9.7 이전의 버전에서는 여전히 기존과 같이 동작합니다.

서버의 PHP 7.2 업그레이드 시 주의 사항

이 배포본에서는 PHP 7.2에 대한 호환성 문제를 고쳤으나,
PHP 7.2 이상의 환경에서는 PHP 7.2에 대응하지 않은 확장 기능 사용시에 문제를 겪을 수 있으므로
PHP 7.2 이상에서는 확장 기능 사용 시 주의 하시기 바랍니다.

관련 정보는 https://www.xpressengine.com/devlog/23249915 에서 찾아볼 수 있습니다.

Core 업데이트 주의 사항

  • 실 사이트에 적용하시기 전에 실 사이트와 유사한 환경을 갖추고 이상이 없는지 확인하시길 권고합니다.
  • 업데이트 전 관리자 로그인 상태로 관리페이지를 열어두시고 진행하시길 권고합니다.
  • 업데이트 후 대시보드에서 각 모듈의 DB 생성 및 업데이트 버튼을 누르세요.
  • 업데이트 순서는 'menu > module > 기타 모듈'순서로 해 주시기 바랍니다.
  • 업데이트 후 관리페이지 우측 하단의 캐시파일 재생성으로 cache를 갱신하셔야 합니다.
  • 1.4 및 1.5 버전에서 업데이트하는 경우 데이터 양에 따라 시간이 많이 소요될 수 있으며 서버 환경에 따라 업데이트에 실패할 수 있습니다.
  • 다음 문서를 참고하여 데이터 백업 후 진행하시길 권고합니다.
  • http://www.xpressengine.com/22674246

문제 발견 시 알려주세요

이 버전에서 발견된 문제는 XE Core 프로젝트 페이지에 이슈를 작성해주시기 바랍니다.

신규 보안 취약점 포상제

XE의 보안취약점의 빠른 발견과 해결을 위해 신규 보안취약점에 대한 신고 포상제를 시행합니다.

그동안 XE 보안취약점은 한국인터넷진흥원(KISA)를 통해 접수되어 통보받는 형태로 운영되어 왔습니다.
하지만 신고자와의 긴밀한 연락이 불가하고, 신고자의 정보를 파악할 수 없어 오픈소스 소프트웨어의 공헌자로서 그 이름을 알리지 못했었습니다.

지속적으로 보안 취약점을 발견하고 해결해나가기위해 자체적인 보안 취약점 신고 절차와 신규 보안 취약점 신고자에 대한 포상제를 시행합니다.

보안 취약점 신고 포상제 페이지를 통해 보안 취약점의 신고 절차를 확인할 수 있습니다.

많은 분들이 공헌해주셨습니다

XE는 자유소프트웨어로서 공개 프로젝트로 운영하고 있습니다.
XE Core 프로젝트 페이지에서 버그 보고 및 개선 제안과 개발에 참여할 수 있습니다.

XE 1.9 미리보기

XE Demo에서 XE 1.9을 미리 사용해볼 수 있습니다.

초기 설치 상태 그대로의 모습으로 최고관리자 권한을 이용해 쉬운설치 및 XE 1.8의 모든 기능을 체험해볼 수 있습니다.

다운로드

XE Core 다운로드 페이지에서 XE 최신 버전을 다운로드할 수 있습니다.

이 버전의 직전 버전을 사용 중이신 경우 변경된 파일(파일명에 'changed'가 포함된 파일)만 내려받아 업데이트할 수 있습니다.

변경 내역

Defect

  • #2008 첨부파일에 & 문자열이 포함된 경우 다운로드 파일명이 깨져보일 수 있는 문제 고침 @bnu @botserv
  • #2025 감춰진 문자 등을 이용한 중복 닉네임 사용 가능 문제 고침 @bnu @huhani
  • #2269 사파리에서 파일명이 유니코드일 때 index.php 파일명으로 저장될 수 있는 문제 고침 @bnu @wonsuc
  • #2271 importer 모듈에서 규칙에 맞지 않는 아이디 등을 적절하게 변경하여 데이터를 이전할 수 있도록 개선 @kijin @bnu
  • 124d119 REQUEST_URI 활용 시 허용되지 않은 문자열이 포함될 수 있는 문제 고침 @bnu @kijin

Enhancement

  • #2112 인증메일 24시간 제한 때문에 인증 불가 시 안내 메시지 개선 @bnu @wookho
  • #2255 첨부 이미지 삭제 시 본문에 추가된 img 태그 제거 @bnu @wookho
  • #2266 연결되지 않는 외부 사이트 링크 수정 @dorami @bnu

For Developers

  • #2263 debug 파일을 생성하지 못하거나 삭제하지 못하는 문제 고침 @bnu @kndol
  • #2267 #2268 JSON 타입으로 게시물 목록를 호출 시 본문 내용을 가져오지 못하는 문제 고침 @bnu @kndol
  • #2275 포함되지 못했던 jQuery UI 1.12.1 버전으로 업데이트 적용 @bnu @wookho
제목 최종 글 날짜
공지 [중요-수정] XE 1.11.0 버전의 중요 변경사항 안내 (최종 수정: 2018년 10월 08일 19시 18분) [1] 2018.10.10 by gu곰 2018.09.19
공지 [중요!] Object 클래스의 이름 변경 안내(PHP 7.2 버전 호환성) [1] 2017.11.28 by 엘카 2017.11.27
공지 XE 신규 보안취약점 신고 포상제 시행 안내 [1] 2017.02.25 by 댑펑 2016.09.30
[보안패치] XE 1.11.0 버전 배포 안내 [3] 2018.10.11 by gu곰 2018.10.10
XE Open Seminar 01 - 2018년 10월 18일 [3] file 2018.09.28 by sejin7940 2018.09.27
[행사안내] AMP Roadshow Seoul   2018.09.05
XE Core 1.9.8 버전 배포 안내 [1] 2018.08.23 by 풀스텍 2018.08.01
XE Core 1.9.7 배포 안내   2018.06.07
공지 XE 개발자 채용 안내 (~2018.06.29)   2018.06.01
[보안 패치] XE 1.9.6 배포 안내 (1.9.5 포함) [2] 2018.06.15 by 벅바 2018.03.07
[보안 패치] XE 1.9.4 배포 안내   2018.03.06
XE 1.9.3 버전 배포 안내 [1] 2018.02.09 by 에릭리카드 2018.01.09
[취소] XE Core 1.10의 PHP 지원 버전 변경 안내 [1] file 2018.03.22 by uwan**** 2018.01.04
XE 개발자 채용 안내   2018.01.02
XE 1.9.2(1.9.1 포함) 배포 안내 (OPcache 문제 수정) [2] 2017.12.13 by 마카리아 2017.12.07
[보안패치] XE 1.9.0 배포 안내 (PHP 7.2 호환성 개선) [12] 2017.12.04 by XE 2017.11.30
[보안패치] XE Core 1.8.46 배포 안내 [6] 2017.10.27 by 숭숭군 2017.10.19
[보안패치] XE Core 1.8.45 버전 배포 안내 [5] 2017.10.01 by 우랑탕탕이 2017.09.12
[보안패치] XE Core 1.8.44 버전 배포 안내 [1] 2017.09.12 by 웹마스터 2017.09.12
[보안패치] XE Core 1.8.43 버전 배포 안내 [5] 2017.08.27 by 흑묘백묘 2017.08.17
XE Open Office Day - XE3 Boot up #1   2017.08.17