메뉴 건너뛰기

innoDB 사용이 강제되는 건가요 'ㅅ'a

SSH 설치 웹설치 동일하게 에러가 납니다.

 

[Illuminate\Database\QueryException]
SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 1000 bytes (SQL: alter ta
ble xe_files add unique findKey(disk, path, filename))

 

[PDOException]
SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 1000 bytes


innoDB 사용을 강제로 disable 시킨 상태 인데 (my.cnf - skip-innodb / default-storage-engine = MYISAM)
unique key 로 사용되는 path컬럼의 키값 길이varchar(255) 가 너무 긴거 같은데 ( varchar 최대값은 myisam - utf8 에서는 166 이죠.. )
MyiSAM 은 포기하는 부분 인가요?

 

hotbackup 방식으로 백업 서비스를 운용하기 때문에 innodb 를 허용할 수 없는데 말이죠 'ㅅ'a


기존 XE에서 글,코멘트,트랙백,회원가입 스팸이 기본값에서 막들어오는 상태라
엉망이었기 때문에 innodb 운영시 ibdata 파일이 커지는 부분을 감당할수 없는 부분도 있구요.

  • share