XE 공식 자료실

XE 코어 XE Core ver. 1.9.6

제작자
XE
등록일
2018-03-07
다운로드 수
11,361
링크1
www.xpressengine.com
링크2
xpressengine/xe-core

XpressEngine의 설치부터 운영에 필요한 가장 중요한 내용이 있는 Core 배포판입니다. XpressEngine의 모든 프로그램/스킨등은 XpressEngine Core가 있어야 합니다.

라이선스
LGPL v2
설치경로
.
최초 등록일
2009-09-24
전체 다운로드
2,045,558
체험하기

쉬운설치로 바로 체험할 수 있습니다

스크린샷

상세 설명

XpressEngine Core 1.9.6 버전을 배포합니다.

이 버전에서는 보안 취약점이 고쳐졌습니다.
1.9.5에서 에디터 모듈을 업데이트 할 수 없는 문제를 고쳤습니다.

서버의 PHP 7.2 업그레이드 시 주의 사항

이 배포본에서는 PHP 7.2에 대한 호환성 문제를 고쳤으나,
PHP 7.2 이상의 환경에서는 PHP 7.2에 대응하지 않은 확장 기능 사용시에 문제를 겪을 수 있으므로
확장 기능 사용 시 주의 하시기 바랍니다.

이는 PHP 7.2 이상의 서버 환경에서만 발현될 수 있으며, PHP 7.1.x 이하 서버에는 영향을 주지 않습니다.

관련 정보는 https://www.xpressengine.com/devlog/23249915 에서 찾아볼 수 있습니다.

Core 업데이트 주의 사항

  • 실 사이트에 적용하시기 전에 실 사이트와 유사한 환경을 갖추고 이상이 없는지 확인하시길 권고합니다.
  • 업데이트 전 관리자 로그인 상태로 관리페이지를 열어두시고 진행하시길 권고합니다.
  • 업데이트 후 대시보드에서 각 모듈의 DB 생성 및 업데이트 버튼을 누르세요.
  • 업데이트 순서는 'menu > module > 기타 모듈'순서로 해 주시기 바랍니다.
  • 업데이트 후 관리페이지 우측 하단의 캐시파일 재생성으로 cache를 갱신하셔야 합니다.
  • 1.4 및 1.5 버전에서 업데이트하는 경우 데이터 양에 따라 시간이 많이 소요될 수 있으며 서버 환경에 따라 업데이트에 실패할 수 있습니다.
  • 다음 문서를 참고하여 데이터 백업 후 진행하시길 권고합니다.
  • http://www.xpressengine.com/22674246

문제 발견 시 알려주세요

이 버전에서 발견된 문제는 XE Core 프로젝트 페이지에 이슈를 작성해주시기 바랍니다.

신규 보안 취약점 포상제

XE의 보안취약점의 빠른 발견과 해결을 위해 신규 보안취약점에 대한 신고 포상제를 시행합니다.

그동안 XE 보안취약점은 한국인터넷진흥원(KISA)를 통해 접수되어 통보받는 형태로 운영되어 왔습니다.
하지만 신고자와의 긴밀한 연락이 불가하고, 신고자의 정보를 파악할 수 없어 오픈소스 소프트웨어의 공헌자로서 그 이름을 알리지 못했었습니다.

지속적으로 보안 취약점을 발견하고 해결해나가기위해 자체적인 보안 취약점 신고 절차와 신규 보안 취약점 신고자에 대한 포상제를 시행합니다.

보안 취약점 신고 포상제 페이지를 통해 보안 취약점의 신고 절차를 확인할 수 있습니다.

많은 분들이 공헌해주셨습니다

XE는 자유소프트웨어로서 공개 프로젝트로 운영하고 있습니다.
XE Core 프로젝트 페이지에서 버그 보고 및 개선 제안과 개발에 참여할 수 있습니다.

XE 1.9 미리보기

XE Demo에서 XE 1.9을 미리 사용해볼 수 있습니다.

초기 설치 상태 그대로의 모습으로 최고관리자 권한을 이용해 쉬운설치 및 XE 1.8의 모든 기능을 체험해볼 수 있습니다.

다운로드

XE Core 다운로드 페이지에서 XE 최신 버전을 다운로드할 수 있습니다.

이 버전의 직전 버전을 사용 중이신 경우 변경된 파일(파일명에 'changed'가 포함된 파일)만 내려받아 업데이트할 수 있습니다 (1.9.5의 변경 내역을 포함 함).

변경 내역 (1.9.5의 변경 내역을 포함 함)

Defect

  • #2238 2229 이슈 처리 중 컬럼 추가 등이 잘못된 문제 @bnu @Lastorder-DC @kijin
  • #2220 #2237 cond, loop 등 템플릿 코드가 컴파일 되지 않고 출력되는 문제 @bnu @wookho @kijin
    • 일부 해결됨을 확인하였으나, 다양한 환경에서 문제가 여전히 나타날 수 있음
  • 1.9.5에서 에디터 모듈을 업데이트 할 수 없는 문제 고침 @bnu @laiglinne-ff

포럼 2

로그인 후 작성할 수 있습니다.
  • 2018-03-10 09:32:42 장년

    변경되기 전, 195로 되어있는 파일을 받았던 사람들은 다시 변경된 196으로 올려야 하나요?

  • 2018-03-07 23:01:02 sejin7940

    1.9.6 changed file 이 1.9.5 changed file 내역을 다 포함하고 있다는거죠?
    그런데 변뎡된파일의 링크주소가 잘못 걸려있네요 ( 1.9.5 로 되어있어요 )
    https://github.com/xpressengine/xe-core/releases/tag/1.9.6 로 변경해주세요